System requirements for supported MindManager versions

1 users found this article helpful

You can find the system requirements for our supported MindManager versions here.

Windows

MindManager Windows 22

Supported operating systems:

Microsoft® Windows® 11 32-bit and 64-bit
Microsoft® Windows® 10 32-bit and 64-bit

Additional requirements:

Additional requirements to use certain features:

MindManager Windows 21

Supported operating systems:

Microsoft® Windows® 10 (32-bit and 64-bit)

Additional requirements:

Additional requirements to use certain features:


MindManager 2020 for Windows

Supported operating systems:

Microsoft® Windows® 10 (32-bit and 64-bit)
Microsoft® Windows® 7 Service Pack 1, (32-bit and 64-bit)

Additional requirements:

Additional requirements to use certain features:

 

 

 

Mac

MindManager Mac 14

Supported operating systems: 

macOS® Mojave 10.14 to macOS® Monterey 12.0
 

Additional requirements:

Additional requirements to use certain features:

MindManager Mac 13

Supported operating systems: 

macOS® High Sierra 10.13 to macOS® Monterey 12.0
 

Additional requirements:

Additional requirements to use certain features:

 

MindManager 12 for Mac

Supported operating systems:

macOS® 10.13 (High Sierra) to 11.0 (Big Sur)

Additional requirements:

Additional requirements to use certain features:

 

Was this article helpful?

Tell us how we can improve it.