Why are MindManager versions no longer supported?

0 users found this article helpful

Why are MindManager versions no longer supported?

MindManager periodically “retires” older versions of its software in order to focus resources on developing and supporting newer versions.
When a version of MindManager software is “retired,” live Technical Support is discontinued for that version. Self-service support through the knowledge base and forums remains available.
We no longer offer upgrade options for not supported versions.
To find out which MindManager version are no longer supported, visit the Product Lifecycle Policy page.

Note on perpetual licenses

Even though our "perpetual" licenses are in principle valid for an unlimited period of time, technical progress of hardware and software may mean that these licenses cannot be used in practice for an unlimited period of time. Because legacy licenses may not be compatible with new operating system versions or computers, in certain situations, upgrading to a current version of MindManager may be necessary to ensure safe operation.

To see the system requirements for supported MindManager versions, visit this page.
To see the system requirements for not supported MindManager versions, visit this page.

 

Was this article helpful?

Tell us how we can improve it.